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Introduction
The RF Module is used by engineers and scientists to understand, predict, and design 
electromagnetic wave propagation and resonance effects in high-frequency 
applications. Simulations of this kind result in more powerful and efficient products 
and engineering methods. It allows its users to quickly and accurately predict 
electromagnetic field distributions, transmission, reflection, and power dissipation in 
a proposed design. Compared to traditional prototyping, it offers the benefits of 
lower cost and the ability to evaluate and predict entities that are not directly 
measurable in experiments. It also allows the exploration of operating conditions 
that would destroy a real prototype or be hazardous.

This module covers electromagnetic fields and waves in two-dimensional and 
three-dimensional spaces along with traditional circuit-based modeling of passive and 
active devices. All modeling formulations are based on Maxwell’s equations or 
subsets and special cases of these together with material laws for propagation in 
various media. The modeling capabilities are accessed via predefined physics 
interfaces, referred to as RF interfaces, which allow you to set up and solve 
electromagnetic models. The RF interfaces cover the modeling of electromagnetic 
fields and waves in frequency domain, time domain, eigenfrequency, and mode 
analysis.

Under the hood, the RF interfaces formulate and solve the differential form of 
Maxwell’s equations together with the initial and boundary conditions. The equations 
are solved using the finite element method with numerically stable edge element 
discretization in combination with state-of-the-ar t algorithms for preconditioning and 
solution of the resulting sparse equation systems. The results are presented using 
predefined plots of electric and magnetic fields, S-parameters, power flow, and 
dissipation. You can also display your results as plots of expressions of the physical 
quantities that you define freely, or as tabulated derived values obtained from the 
simulation.

The work flow is straightforward and can be described by the following steps: define 
the geometry, select materials, select a suitable RF interface, define boundary and 
initial conditions, define the finite element mesh, select a solver, and visualize the 
results. All these steps are accessed from the COMSOL Desktop. The solver step is 
usually carried out automatically using default settings, which are tuned for each 
specific RF interface.
Introduction | 5
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The RF Module’s Model Library describes the interfaces and their different features 
through tutorial and benchmark examples for the different formulations. The library 
includes models from RF and microwave engineering, optics and photonics, tutorial 
models for education, and benchmark models for verification and validation of the 
RF interfaces.

This introduction is intended to give you a jump star t in your modeling work. It has 
examples of the typical use of the RF Module, a list of the interfaces with a short 
description, and a tutorial example that introduces the modeling workflow.

The Use of the RF Module
The RF interfaces are used to model electromagnetic fields and waves in high 
frequency applications. The latter means that it covers the modeling of devices that 
are above about 0.1 electromagnetic wavelength in size. Thus, it may be used to 
model microscale optical devices or for human size devices operating at frequencies 
above 10 MHz.

RF simulations are frequently used to extract S-parameters characterizing the 
transmission and reflection of a device. Figure 1 shows the electric field distribution 
in a dielectric loaded H-bend waveguide component. A rectangular TE10 waveguide 
mode is launched into an inport at the near end of the device and absorbed by the 
outport at the far end. The bend region is filled by silica glass.

Figure 1: Electric field distribution in a dielectric loaded H-bend waveguide. From the RF Module Model 
Library model H-Bend Waveguide 3D.
6 | Introduction
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The transmission and reflection of the device is obtained in the form of 
S-parameters, as in Figure 2.

Figure 2: The S-parameters, on a dB scale, as a function of the frequency. 

S-parameters can be exported in the Touchstone file format for fur ther use in system 
simulations and are, by themselves, useful performance measures of a design.

In Figure 3 and Figure 4, a model from the RF Module Model Library shows how a 
human head absorbs a radiated wave from an antenna held next to the ear. The 
temperature is increased by the absorbed radiation.
Introduction | 7
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Figure 3: The local increase in temperature in a human head due to absorption of electromagnetic energy 
from an antenna held next to the ear. From the RF Module Model Library model Absorbed Radiation 
(SAR) in the Human Brain.

The SAR (specific absorption rate) value is of specific interest to designers of mobile 
telephones and is readily obtained from the simulation.

Figure 4: Log-scale slice plot of the local specific absorption rate (SAR) in a human head.
8 | Introduction
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The RF Module also offers a comprehensive set of features for 2D modeling including 
both source driven wave propagation and mode analysis. Figure 5 shows mode 
analysis of a step-index profile optical fiber.

Figure 5: The surface plot visualizes the longitudinal component of the electric field in the fiber core. From 
the RF Module Model Library model Step Index Fiber. 

Both in 2D and 3D, the analysis of periodic structures is popular. Figure 6 is an 
example of wave propagation in a photonic crystal. 

Figure 6: The out-of-plane component of the electric field shows how the wave is confined to propagate 
along a path defined by removing some pillars in the photonic crystal. From the RF Module Model Library 
model Photonic Crystal. 
Introduction | 9
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It is also possible to perform Body-of-Revolution (BOR) simulations in 2D 
axisymmetry. Figure 7 illustrates the modeling of a monoconical antenna with coaxial 
feed.

Figure 7: Axisymmetric model of a monoconical antenna with coaxial feed. The azimuthal component of 
the magnetic field is shown. From the RF Module Model Library model Conical Antenna.

The RF Module has a vast range of tools to evaluate and export the results, for 
example, evaluation of far-field, feed impedance, and scattering matrices 
(S-parameters). S-parameters can be exported in the Touchstone file format.

The combination of full-wave electromagnetic field modeling and simplified 
circuit-based modeling is the ideal basis for design, exploration, and optimization. 
More complex system models can be exploited using circuit-based modeling while 
maintaining links to full field models for key devices in the circuit allows for design 
innovation and optimization on both levels.

The RF Module Interfaces
The RF interfaces are based upon Maxwell’s equations or subsets and special cases 
of these together with material laws. In the module, these laws of physics are 
translated by the RF interfaces to sets of partial differential equations with 
corresponding initial and boundary conditions.

The RF physics define a number of features. Each feature represents an operation 
that describes a term or condition in the underlying Maxwell-based formulation. Such 
10 | Introduction
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a term or condition may be defined in a geometric entity of the model, such as a 
domain, boundary, edge (for 3D models), or point. 

Figure 8 uses the Coaxial Waveguide Coupling model from the RF Module Model 
Library to show the Model Builder window and the settings window for the selected 
Wave Equation, Electric 1 feature node. The Wave Equation, Electric 1 node adds 
the terms to the model equations to a selected geometrical domain representing the 
Electromagnetic Waves domain in the model.

Furthermore, the Wave Equation, Electric 1 feature node may link to the Materials 
feature node to obtain physical properties such as relative permittivity, in this case 
the relative permittivity of a user-defined dielectric. The properties, defined by the 
Dielectric material, can be functions of the modeled physical quantities, such as 
temperature. In the same fashion, the Perfect Electric Conductor 1 boundary 
Introduction | 11
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condition feature adds the reflecting boundary conditions that limit the 
Electromagnetic Waves domain. 

Figure 8: The Model Builder (left), and the Wave Equation, Electric settings window (right). The Equation 
section shows the model equations and the terms added by the Wave Equation, Electric 1 node to the 
model equations. The added terms are underlined with a dotted line. The text also explains the link 
between the Dielectric node and the values for the relative permittivity.

The figure below shows the RF interfaces as displayed in the Model Wizard for this 
module. 

This module includes RF interfaces ( ) for frequency-domain modeling and 
time-domain modeling, respectively. It also has the Microwave Heating interface 
12 | Introduction
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found under Heat Transfer. Also see “Physics List by Space Dimension and Study 
Type” on page 14. A brief overview of the RF interfaces follows.

E L E C T R O M A G N E T I C  W A V E S ,  F R E Q U E N C Y  D O M A I N

The Electromagnetic Waves, Frequency Domain interface ( ) solves a 
frequency-domain wave equation for the electric field given its sources. The sources 
can be in the form of point dipoles, line currents, or incident fields on boundaries or 
domains. It is used primarily to model electromagnetic wave propagation in different 
media and structures. Variants of the formulation solves an eigenvalue problem to 
find the eigenfrequencies of a structure or, at a prescribed frequency, solves an 
eigenvalue problem to find the propagating modes in waveguides and transmission 
lines. Some typical applications that are simulated in the interface are waveguides and 
transmission lines, filters and resonators, antennas, and RF connectors and couplers. 

E L E C T R O M A G N E T I C  W A V E S ,  TR A N S I E N T

The Transient Electromagnetic Waves, Transient interface ( ) solves a 
time-domain wave equation for the electric field given its sources. The sources can 
be in the form of point dipoles, line currents, or incident fields on boundaries or 
domains. It is used primarily to model electromagnetic wave propagation in different 
media and structures when a time-domain solution is required—for example, for 
non-sinusoidal waveforms or for nonlinear media. Typical applications involve the 
propagation of electromagnetic pulses and the generation of harmonics in nonlinear 
optical media.

TR A N S M I S S I O N  L I N E

The Transmission Line interface ( ), solves the time-harmonic transmission line 
equation for the electric potential. The interface is used when solving for 
electromagnetic wave propagation along one-dimensional transmission lines and is 
available in 1D, 2D and 3D. The Eigenfrequency and Frequency Domain study types 
are available. The frequency domain study is used for source driven simulations for a 
single frequency or a sequence of frequencies. Typical applications involve the design 
of impedance matching elements and networks.

M I C R O W A V E  H E A T I N G

The Microwave Heating interface ( ) combines the features of an Electromagnetic 
Waves, Frequency Domain interface with those of the Heat Transfer interface. The 
predefined interaction adds the electromagnetic losses from the electromagnetic 
Introduction | 13
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waves as a heat source. This interface is based on the assumption that the 
electromagnetic cycle time is short compared to the thermal time scale (adiabatic 
assumption). 

E L E C T R I C A L  C I R C U I T S

The Electrical Circuit interface ( ) can be connected to an RF interface. The 
lumped voltage and current variables from the circuits are translated into boundary 
conditions applied to the distributed field model. Typical applications include the 
modeling of transmission lines and antenna feeding.

Physics List by Space Dimension and Study Type
The table below list the interfaces available specifically with this module in addition 
to the COMSOL Multiphysics basic license. 

Opening the Model Library
To open any RF Module Model Library model, select View > Model Library  from 
the main menu in COMSOL Multiphysics. In the Model Library window that opens, 
expand the RF Module folder and browse or search the contents. Click Open Model 

PHYSICS ICON TAG SPACE DIMENSION PRESET STUDIES

  AC/DC

Electrical Circuit cir Not space 
dependent

stationary; frequency domain; time 
dependent

  Heat Transfer

 Electromagnetic Heating

Microwave Heating mh 3D, 2D, 2D 
axisymmetric

stationary; frequency domain; time 
dependent; boundary mode analysis; 
frequency-stationary; frequency 
transient

  Radio Frequency

Electromagnetic Waves emw 3D, 2D, 2D 
axisymmetric

eigenfrequency; frequency domain; 
frequency-domain modal; boundary 
mode analysis

Transient 
Electromagnetic Waves

temw 3D, 2D, 2D 
axisymmetric

eigenfrequency; time dependent; time 
dependent modal

Transmission Line tl 3D, 2D, 1D eigenfrequency; frequency domain
14 | Introduction
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and PDF to open the model in COMSOL Multiphysics and a PDF to read background 
theory about the model including the step-by-step instructions to build it.

The MPH-files in the COMSOL model libraries can have two formats—Full MPH-files 
or Compact MPH-files.

• Full MPH-files, including all meshes and solutions. In the Model Library these 
models appear with the  icon. If the MPH-file’s size exceeds 25MB, a tip with 
the text “Large file” and the file size appears when you position the cursor at the 
model’s node in the Model Library tree.

• Compact MPH-files with all settings for the model but without built meshes and 
solution data to save space on the DVD (a few MPH-files have no solutions for 
other reasons). You can open these models to study the settings and to mesh and 
re-solve the models. It is also possible to download the full versions—with meshes 
and solutions—of most of these models through Model Library Update. In the 
Model Library these models appear with the  icon. If you position the cursor 
at a compact model in the Model Library window, a No solutions stored message 
appears. If a full MPH-file is available for download, the corresponding node’s 
context menu includes a Model Library Update item.

A model from the Model Library is used as a tutorial in this guide. See “Tutorial 
Example: Impedance Matching of a Lossy Ferrite 3-port Circulator”, which star ts on 
the next page.
Introduction | 15
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Tutorial Example: Impedance Matching of a Lossy Ferrite 
3-port Circulator

Introduction
A microwave circulator is a nonreciprocal multiport device. It has the property that 
a wave incident on port 1 is routed into port 3 but a wave incident on port 3 is not 
routed back into port 1 but is instead routed into port 2, and so on. This property 
of circulators is used to isolate microwave components from each other. A typical 
example is when connecting a transmitter and a receiver to a common antenna. By 
connecting the transmitter, receiver, and antenna to different ports of a circulator, the 
transmitted power is routed to the antenna whereas any power received by the 
antenna goes into the receiver. Circulators typically rely on the use of ferrites, a 
special type of highly permeable and low-loss magnetic material that is anisotropic 
for a small RF signal when biased by a much larger static magnetic field. In the 
example, a three-port circulator is constructed from three rectangular waveguide 
sections joining at 120 and with a ferrite post inserted at the center of the joint.

The post is magnetized by a static H0 bias field along its axis. The bias field is supplied 
by external permanent magnets which are not explicitly modeled in this tutorial. 

Port 3

Ferrite post 

Port 2

Port 1
16 | Tutorial Example: Impedance Matching of a Lossy Ferrite 3-port Circulator
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Impedance Matching
An important step in the design of any microwave device is to match its input 
impedance for a given operating frequency. Impedance matching is equivalent to 
minimizing the reflections at the inport. The parameters that need to be determined 
are the size of the ferrite post and the width of the wider waveguide section 
surrounding the ferrite. In this tutorial, these are varied in order to minimize the 
reflectance. The scattering parameters (S-parameters) used as measures of the 
reflectance and transmittance of the circulator are automatically computed.

The nominal frequency for the design of the device is selected to 3 GHz. The 
circulator can be expected to perform reasonably well in a narrow frequency band 
around 3 GHz so a frequency range of 2.6 – 3.4 GHz is studied. It is desired that the 
device operates in single mode. Thus a rectangular waveguides cross section of 
6.67 cm by 3.33 cm is selected. This sets the cut-off frequency for the fundamental 
TE10 mode to 2.25 GHz. The cut-off frequencies for the two nearest higher modes, 
the TE20 and TE01 modes, are both at 4.5 GHz, leaving a reasonable safety margin.

Model Definition
One of the rectangular por ts is excited by the fundamental TE10 mode. At the ports, 
the boundaries are transparent to the TE10 mode. The following equation applies to 
the electric field vector E inside the circulator :

where r denotes the relative permeability tensor,  the angular frequency,  the 
conductivity tensor, 0 the permittivity of vacuum, r the relative permittivity tensor, 
and k is the free space wave number. The conductivity is zero everywhere. Losses 
in the ferrite are introduced as complex-valued permittivity and permeability tensors. 
The magnetic permeability is of key importance as it is the anisotropy of this 
parameter that is responsible for the nonreciprocal behavior of the circulator. For 
simplicity, the rather complicated material expressions are predefined in a text file 
that is imported into the model. As a reference, the expressions are also included in 
the next section.

The Lossy Ferrite Material Model
Complete treatises on the theory of magnetic proper ties of ferrites can be found in 
Ref. 1 and Ref. 2. The model assumes that the static magnetic bias field, H0, is much 
stronger than the alternating magnetic field of the microwaves, so the quoted 

r
1– E  k0

2 r
j
0
---------– 

 E– 0=
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expressions are a linearization for a small-signal analysis around this operating point. 
Under these assumptions, and including losses, the anisotropic permeability of a 
ferrite magnetized in the positive z direction is given by:

where

and the unique elements of the magnetic susceptibility tensor are given by:

where

Here 0 denotes the permeability of free space;  is the angular frequency of the 
microwave field; 0 is the precession resonance frequency (Larmor frequency) of a 
spinning electron in the applied magnetic bias field, H0; m is the electron Larmor 
frequency at the saturation magnetization of the ferrite, Ms; and  is the gyromagnetic 
ratio of the electron. For a lossless ferrite (), the permeability becomes infinite 
at 0. In the lossy ferrite (), this resonance becomes finite and is broadened. 
The loss factor, , is related to the line width, H, of the susceptibility curve near the 
resonance as given by the last expression above. The material data, 

 
 j 0
j–  0
0 0 0
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-------------------------------------------------------------------------------------- j
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Ms = 5.41·104 A/m, r = 14.5

with an effective loss tangent of 2·10-4 and H= 3.18·103 A/m, are taken for aluminum 
garnet from Ref. 2. The applied bias field is set to H0 = 7.96·103 A/m. The electron 
gyromagnetic ratio taken from Ref. 2 is 1.759·1011 C/kg.

References
1. R.E. Collin, Foundations for Microwave Engineering, 2nd ed., IEEE Press/Wiley-Interscience, 

2000.

2. D.M. Pozar, Microwave Engineering, 3rd ed., John Wiley & Sons Inc, 2004.

MODEL WIZARD

These step-by-step instructions guide you through the design and modeling of the 
lossy three-port circulator in 3D. The first part involves the geometric design and 
impedance matching at a nominal frequency of 3 GHz. After that, a frequency sweep 
is performed to see how well it performs in a frequency band of 400 MHz centered 
at 3 GHz. Finally, computation and a Touchstone file export of the entire S-parameter 
matrix is performed.

1 Open COMSOL Multiphysics. In the Model Wizard, the default Space Dimension is 3D. 
Click Next .

2 In the Add Physics tree under Radio Frequency, double-click Electromagnetic Waves, 
Frequency Domain  to add it to the Selected physics list. Click Next .

3 Under Studies>Preset Studies click Frequency Domain .

4 Click Finish .

GLOBAL DEFINITIONS -  PARAMETERS AND VARIABLES

The geometry is set up using a parameterized approach. This allows you to match 
the input impedance to that of the connecting waveguide sections by variation of two 
geometric design parameters. These are dimensionless numbers used to scale 
selected geometric building blocks.
Tutorial Example: Impedance Matching of a Lossy Ferrite 3-port Circulator | 19
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Note: In this section, two parameters are entered and a set of variables imported from 
a file to prepare for drawing the circulator geometry, which is described in the section 
“Geometry Sequence” on page 40. Alternatively, a predefined Model Library file 
containing the geometry, parameters, and variables can be imported, as described in 
“Geometry” on page 21. If you import the geometry, you only need to review this 
section for information.

1 In the Model Builder, right-click Global Definitions  and select Parameters .

2 In the Parameters settings window under Parameters, enter these settings in the 
Parameters table.

The lossy ferrite material model is set up by referring to global variables. For 
convenience the definitions are stored in an external text file that is imported into 
the model. The external text file also contains comments.

Note: The location of the text files vary based on the installation. For example, if the 
installation is on your hard drive, the file path might be similar to C:\Program 
Files\COMSOL43\models\. 

1 In the Model Builder, right-click Global Definitions  and choose Variables .

2 Go to the Variables settings window. Under Variables click Load from File .

3 Browse to the Model Library folder \RF_Module\RF_and_Microwave_Engineering and 
double-click the file lossy_circulator_3d_parameters.txt. The variables are 
imported into the table.
20 | Tutorial Example: Impedance Matching of a Lossy Ferrite 3-port Circulator
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GEOMETRY

In the Global Definitions section, you entered parameters and imported variables in 
preparation for drawing the geometry. To learn how to draw the circulator, go to 
“Geometry Sequence” on page 40. 

To save time, a predefined model containing the parameters, variables, and geometry 
can instead be opened from the Model Library. 

1 From the View menu, select Model Library . 

2 In the Model Library, under RF Module>RF and Microwave Engineering double-click 
lossy_circulator_3d_geom to open it. 

Once the geometry is either drawn or imported, you can then experiment with 
different dimensions and update the values of sc_chamfer and sc_ferrite and 
re-run the geometry sequence.

MATERIALS

The next step is to add material settings to the model. The air that fills most of the 
volume is available as a built-in material. The lossy ferrite has material assigned to it 
later, and illustrates how external material data can also be entered directly into the 
electromagnetic waves model. The walls of the waveguide sections are modeled as 
perfect conductors and do not require a material.

1 From the main menu, select View>Material Browser .

2 Go to the Material Browser window. In the 
Materials tree under Built-In, right-click Air 
and choose Add Material to Model .
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ELECTROMAGNETIC WAVES, FREQUENCY DOMAIN 

The ferrite enters in the physics interface as a separate, user-defined equation model, 
referring to the global variables defined on page 19.

Wave Equation, Electric 2
1 In the Model Builder right-click Electromagnetic Waves, Frequency Domain (emw)  node 

and at the domain level choose Wave Equation, Electric . 

A Wave Equation, Electric 2 node is added to the 
Model Builder. The nodes with a ‘D’ in the upper left 
corner indicate a default node.

2 Select Domain 2 only.

There are many ways to select geometric entities. When you know the domain to 
add, such as in this exercise, you can click the Paste Selection button  and enter the 
information in the Selection field. In this example enter 2 in the Paste Selection window. 
For more information about selecting geometric entities in the Graphics window, see 
the COMSOL Multiphysics User’s Guide

3 Go to the Wave Equation, Electric settings window. Under Electric Displacement Field: 

- From the Electric displacement field model list, select Dielectric loss.

- From the  list, select User defined. In the associated field, enter eps_r_p. 

- From the  list, select User defined. In the associated field, enter eps_r_b.
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4 Under Magnetic Field from the r list, select 
User defined and Anisotropic.

5 In the r table, enter the settings as in the 
figure to the right.

6 Under Conduction Current from the  list, 
select User defined and leave the default 
value at 0.

Now add ports for excitation and 
transmission.

Port 1, Port 2, and Port 3
1 In the Model Builder, right-click Electromagnetic Waves, Frequency Domain (emw)  and 

at the boundary level choose Port .

2 Select Boundary 1 only.

3 Go to the Port settings window. Under 
Port Properties from the Type of port list, 
select Rectangular. 

4 From the Wave excitation at this port list, 
select On.

5 Right-click Electromagnetic Waves, 
Frequency Domain (emw)  and add 
another Port  node. For Port 2:

- Select Boundary 18

- Select Rectangular as the Type of port 
list

6 Add another Port  node. For Port 3:

- Select Boundary 19

- Select Rectangular as the Type of port list
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The node sequence in the Model Builder 
should match this figure.

MESH

The mesh respects the geometry but in addition some physics related 
considerations are needed. The mesh needs to resolve the local wavelength and, for 
lossy domains, the skin depth. The skin depth in the ferrite is large compared to the 
size of the domain so the main concern is to resolve the local wavelength. This is 
done by providing maximum mesh sizes per domain. The rule of thumb is to use a 
maximum element size that is one fifth of the local wavelength (at the maximum 
frequency) or less.

Free Tetrahedral 1
1 In the Model Builder, right-click Mesh 1  and choose Free Tetrahedral .

2 Right-click Free Tetrahedral 1  and choose Size .

3 Go to the Size settings window. Under 
Geometric Entity Selection from the Geometric 
entity level list, select Domain. 

4 Select Domain 1 only.

5 Under Element Size click the Custom button.

6 Under Element Size Parameters select the 
Maximum element size check box. Enter 1.5e-2 
in the field.

Size 2
1 In the Model Builder, right-click Free 

Tetrahedral 1  and choose Size . A second 
Size node is added to the sequence.

2 Go to the Size settings window. Under 
Geometric Entity Selection from the Geometric 
entity level list, select Domain.

3 Select Domain 2 only.

4 Under Element Size click the Custom button.
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5 Under Element Size Parameters select the Maximum element size check box. Enter 
4.5e-3 in the field.

6 In the Size settings window, click Build All .

The node sequence in the Model Builder should match the 
figure to the left.

The mesh should match the figure below.

STUDY 1

The final step is to solve for the nominal frequency and inspect the results for possible 
modeling errors.

1 In the Model Builder, expand the Study 1 node, then click Step 1: Frequency Domain .

2 Go to the Frequency Domain settings window. Under Study Settings, in the Frequencies 
field, enter 3e9.

3 In the Model Builder, right-click Study 1  and choose Compute .
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RESULTS

Electric Field
The default multislice plot shows the electric field norm. It is best viewed from above, 
so click the Go to XY View  button on the Graphics toolbar.

The electric field norm gives a good indication of where the main power is flowing 
and where there are standing waves due to reflections from the impedance mismatch 
at the center.

DEFINITIONS - PROBES

The remaining work is to vary the two design parameters in order to minimize 
reflections at the nominal frequency. To do this, perform parametric sweeps over the 
design parameters (scale factors). To avoid accumulating a lot of data while solving, 
throw away the solutions and log only the S-parameter representing reflection in a 
table. For this purpose, add a Global Variable Probe to the model.

1 In the Model Builder under Model 1, right-click Definitions  and choose Probes>Global 
Variable Probe .
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2 Go to the Global Variable Probe settings 
window. In the upper-right corner of the 
Expression section, click Replace 
Expression .

3 From the menu, choose Electromagnetic 
Waves, Frequency Domain>Ports> 
S-parameter, dB, 11 component 
(emw.S11dB)(or when you know the 
variable name, enter emw.S11dB in the Expression field).

STUDY 1

Modify the study in order to vary the scale factor determining the size of the ferrite 
post. The study type is still Frequency Domain.

Parametric Sweep
The parametric sweep over the scale factor is added as an extension to the 
frequency domain study. 

1 In the Model Builder, right-click Study 1  and choose Parametric Sweep .

2 Go to the Parametric Sweep settings window. Under Study Settings click Add  under 
the Parameter names table. 

3 In the Parameter names list, select sc_ferrite (geometry scale factor). 

4 Under Study Settings click the Range  button under the Parameter names table.

5 In the Range dialog box:

- In the Start field, enter 0.5.

- In the Step field, enter 0.003.

- In the Stop field, enter 0.53.
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Note: Or enter range(0.5,0.003,0.53) in the Parameter value list. 

6 Click Replace. 

7 Under Output While Solving, select the 
Accumulated probe table check box under 
Probes.

8 Choose Only last from the Keep solutions in 
memory list. 

9 In the Model Builder, right-click Study 1  
and choose Compute  (or press F8).

RESULTS

Probe1D Plot Group 2
The probe with the reflection coefficient versus the scale parameter is automatically 
logged to a table. A dedicated 1D plot group is also created but it plots the 
S-parameter versus frequency. To plot versus the geometry parameter, proceed as 
follows.

1 In the Model Builder under Results, expand the Tables  node.

2 Select Accumulated Probe Table 1 .

3 In the Results window, right-click the freq column and select Delete Column .

Note: The Results window table is by default located in the lower right side of the 
COMSOL Desktop. Or select View>Results  from the main menu to open the 
window.
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4 In the Results window, click the Graph Plot .

The plot of the S-parameter indicates a minimum for a scale factor of 0.518. Freeze 
the parameter at this value and add a new study to vary the next scale factor.

GLOBAL DEFINITIONS - PARAMETERS

1 In the Model Builder under Global Definitions, click Parameters .

2 In the Parameters settings window under Parameters, in the Expression column enter 
0.518 in the sc_ferrite row. 
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STUDY 1

Parametric Sweep
1 In the Model Builder under Study 1, click Parametric Sweep .

2 Go to the Parametric Sweep settings window. Under Study Settings in the Parameter 
names list, select sc_chamfer (Geometry scale factor).

3 Under Study Settings click the Range  button under the Parameter names table.

4 In the Range dialog box:

- In the Start field, enter 2.8.

- In the Step field, enter 0.04.

- In the Stop field, enter 3.2. 

Note: Or enter range(2.8,0.04,3.2) in the Parameter value list. 

5 Click Replace.

6 In the Model Builder, right-click Study 1  and choose Compute .

RESULTS

Probe1D Plot Group 2
Again, the probe with the reflection coefficient versus the frequency is automatically 
logged to a table. To get the desired plot versus the geometry parameter, proceed 
as follows.

1 In the Model Builder, go to Results  and select Accumulated Probe Table 1 .

2 In the Results window, right-click the freq column and select Delete Column .
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In the Results window, click the Graph Plot .

The plot of the S-parameter indicates a minimum for a scale factor of about 3.0. 
Leave the parameter at this value and add a study for the frequency response.

MODEL WIZARD

1 Open the Model Wizard by right-clicking the root 
node and selecting Add Study .

2 Under Preset Studies select Frequency Domain .

3 Click Finish .

ELECTROMAGNETIC WAVES (EMW)

At this stage, it is convenient to partially invoke some higher-level control of what 
port is excited. This is done by letting the value of a parameter decide. The 
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parameter can in turn be controlled by the solver when computing the full 
S-parameter matrix by exciting one port at a time. Another advantage is that when 
this control is activated, a plot group for the S-parameters is automatically created.

1 In the Model Builder click the Electromagnetic Waves, Frequency Domain (emw)  node.

2 Go to the Electromagnetic Waves, Frequency 
Domain settings window. Under Port Sweep 
Settings select the Activate port sweep check 
box.

Note: The default variable name PortName is 
automatically added to the Port parameter name 

field but must be declared as a global parameter 
to be available for the parametric sweep.

GLOBAL DEFINITIONS - PARAMETERS

1 In the Model Builder under Global Definitions, click Parameters .

2 In the Parameters settings window under Parameters:

- In the Name column, enter PortName

- In the Expression column, enter 1

STUDY 2

1 In the Model Builder under Study 2, click Step 1: Frequency 
Domain .

2 Go to the Frequency Domain settings window. Under Study 
Settings click the Range  button.
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3 From the Entry method list, select Number of 
values.

- In the Start field, enter 2.8e9.

- In the Stop field, enter 3.2e9.

- In the Number of values field, enter 21.

4 Click Replace.

5 In the Model Builder, right-click Study 2  
and choose Compute  (or press F8).

RESULTS

The probe with the reflection coefficient versus the frequency is automatically logged 
to a table and plotted while solving. At the last frequency, there are pronounced 
standing waves. Look at the center frequency instead.

1 In the Model Builder under Results, click Electric Field 1 . 

2 Go to the 3D Plot Group settings window. Under Data from 
the Parameter value (freq) list, select 3e9.

3 Click the Plot  button. Click the Go to XY View button .
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At the center frequency most of the standing waves are gone. 

Finally look at all the S-parameters plotted versus the frequency. As the sweep was 
activated a plot group has been created automatically.

This is the frequency response of the final design.

ELECTROMAGNETIC WAVES (EMW)

So far, only the first port has been excited so the full S-parameter matrix remains to 
be calculated by exciting one port at a time. This is also needed in order to confirm 
that the circulator behaves as desired. In the RF Module, this procedure is referred 
to as performing a por t sweep. During this stage, the S-parameters can optionally be 
exported to a Touchstone file for documentation purposes and for use in external 
system simulation tools. Add the name of the Touchstone file.

1 In the Model Builder click the Electromagnetic Waves, Frequency Domain (emw)  node.
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2 Go to the Electromagnetic Waves, Frequency 
Domain settings window. Under Port Sweep 
Settings in the Touchstone file export field, enter : 
lossy_circulator_3d.s3p.

Note: The Touchstone file is saved in the start 
directory of COMSOL Multiphysics unless a 
different file path is specified.

STUDY 1

Reuse the first study for the port sweep. The study is solved for a single frequency 
to keep simulation time to a minimum although it is possible to solve for a range of 
frequencies. All solutions are needed in order to display the S-parameter matrix in a 
table so this setting has to be changed.

Parametric Sweep
The parametric sweep is used to control which port is excited. It overrides the 
settings on individual port features and drives one port at a time using 1 W of input 
power.

1 In the Model Builder under Study 1, click Parametric 
Sweep .

2 Go to the Parametric Sweep settings window. Under 
Study Settings in the Parameter names list, select 
PortName.

3 In the Parameter value list, enter (space 
separated) 1 2 3. 
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4 Under Output While Solving, choose All from the 
Keep solutions in memory list. 

5 In the Model Builder, right-click Study 1  and 
choose Compute .

RESULTS

After the computation finishes, the Touchstone file can be inspected in a text editor. 
The S-parameter matrix can also be displayed in a table.

1 In the Model Builder under Results, right-click Derived Values  and choose Global Matrix 
Evaluation .

2 Go to the Global Matrix Evaluation settings window. Under Data from the Data set list, 
choose Solution 4. 

3 In the upper-right corner of the Expression section, click Replace Expression .
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4 From the menu, choose Electromagnetic Waves, Frequency Domain>Ports>S-parameter, 
dB>S-parameter, dB (emw.SdB). 

5 Click the Evaluate  button and the S-parameter matrix displays in the Results window 
table located in the lower right side of the COMSOL Desktop. Or select 
View>Results  from the main menu to open the Results window. 

Note: The matrix is non-symmetric, which is typical for a device based on a gyrotropic 
material. There are three groups of matrix elements that differ in the fourth digit. These 
should in theory be equal within each group so this gives some indication of the 
discretization errors.
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DEFINITIONS

As a final step, create a plot and also use it as a model thumbnail. From this plot, it 
should be possible to identify the model at first glance so it has to display the 
geometry and some characteristic simulation results. First change to the default 3D 
view and switch off the grid.

1 Click the Go to Default 3D View  button on the Graphics toolbar.

2 In the Model Builder right-click Definitions  and choose View .

3 Go to the View settings window.

4 Under View click to clear the Show grid check box.

RESULTS

1 In the Model Builder under Results, click Electric Field 2 . 

2 Go to the 3D Plot Group settings window. Under Plot 
Settings from the View list, choose View 3. 

3 Click the Plot  button.

Next, delete the multislice and create a single slice.

1 In the Model Builder under Electric Field 2, right-click 
Multislice 1  and choose Delete  (or press Delete on 
the keyboard). 

2 Click Yes to confirm.

3 Right-click Electric Field 2  and choose Slice .

4 In the Slice settings window, under Plane data from the Plane list, choose xy-planes.

5 In the Planes field, enter 1.
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Add a deformation proportional to the electric field to the slice.

1 Right-click Slice 1  and choose Deformation .

2 Go to the Deformation settings window. In the 
upper-right corner of the Expression section, click 
Replace Expression . 

3 From the menu, choose Electromagnetic Waves, 
Frequency Domain>Electric>Electric field 
(emw.Ex,emw.Ey,emw.Ez).

4 Under Expression select the Description check 
box. 

Display the magnetic field as arrows. Use 
logarithmic length scaling to make sure that the 
arrows are clearly visible everywhere. Place the 
arrows well above the slice.

1 In the Model Builder, right-click Electric Field 2  and choose 
Arrow Volume . 

2 Go to the Arrow Volume settings window. In the upper-right 
corner of the Expression section, click Replace Expression .

3 From the menu, choose Electromagnetic Waves, Frequency Domain>Magnetic>Magnetic 
field (emw.Hx,emw.Hy,emw.Hz).

4 Under Expression select the Description check box.

5 Under Arrow Positioning:

- In the Points field for x grid points, enter 
30.

- In the Points field for y grid points, enter 
30 

- For z grid points from the Entry method 
list, select Coordinates.

- For z grid points in the Coordinates field, 
enter 0.1/3.

6 Under Coloring and Style from the Arrow 
length list, choose Logarithmic. From the 
Color list, choose Black.

The port excitation can now be selected for the plot group. For the model thumbnail, 
select the second port.
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1 In the Model Builder, click Electric Field 2 .

2 In the 3D Plot Group settings window under Data, choose 2 from the Parameter value 
(PortName) list.

3 Click the Plot  button.

Select this plot to use as a model thumbnail.

1 In the Model Builder under Results click Electric Field 2 .

2 From the File menu, choose Save Model Thumbnail. 

To view the thumbnail image, click the Root node and look under the Model Thumbnail 
section. 

This concludes the modeling session unless you want to practice drawing a 
“Geometry Sequence” on page 40. 

GEOMETRY SEQUENCE

In “Global Definitions - Parameters and Variables” on page 19 parameters were 
entered to prepare for drawing the circulator geometry. Once the geometry is 
created, you can then experiment with different dimensions and update the values 
of sc_chamfer and sc_ferrite and rerun the geometry sequence. These 
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step-by-step instructions build the same geometry that is contained in the Model 
Library file lossy_circulator_3d_geom (imported in the section “Geometry” on page 21). 

The geometry is built by first defining a 2D cross section of the 3D geometry in a 
work plane. The 2D geometry is then extruded into 3D.

Note: You need to complete the first two sections “Model Wizard” on page 19 and 
“Global Definitions - Parameters and Variables” on page 19 before defining the 
geometry.

Star t by defining one arm of the circulator, then copy and rotate it twice to build all 
three arms.

Rectangle 1
1 In the Model Builder, right-click Geometry 1  and choose Work Plane .

2 Under Work Plane 1 (wp1), click Plane Geometry . 

3 Right-click Plane Geometry  and choose Rectangle .

4 Go to the Rectangle settings window. Under Size in the: 

- Width field, enter 0.2-0.1/(3*sqrt(3)).

- Height field, enter 0.2/3.

5 Under Position in the: 

- xw field, enter -0.2.

- yw field, enter -0.1/3.

6 Click the Build Selected  button.

Copy 1
1 In the Model Builder under Work Plane 1 (wp1), right-click Plane Geometry  and choose 

Transforms>Copy .

2 Select the object r1 by left-clicking (the 
rectangle is highlighted red) and then 
right-click the rectangle (it is highlighted blue). 
The object r1 is added to the Input objects list 
on the Copy settings window. 

3 Click the Build Selected  button.
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Note: To turn on the geometry labels in the Graphics 
window, in the Model Builder under 
Geometry 1>WorkPlane 1>Plane Geometry, click the View 2 
node. Go to the View settings window and select the Show 

geometry labels check box.

Rotate 1
1 In the Model Builder under Work Plane 1 (wp1), right-click 

Plane Geometry  and choose Transforms>Rotate .

2 Select only the object copy1 (left-click twice before right-clicking or you get r1).

3 Go to the Rotate settings window. Under Rotation Angle in the Rotation field, enter 120.

4 Click the Build Selected  button and then click the Zoom Extents button  on the 
Graphics toolbar. The geometry should match the figure so far.

Copy 2
1 Right-click Plane Geometry  and choose Transforms>Copy .

2 Select the object r1 only and add it to the Input objects list in the Copy settings window.

3 Click the Build Selected  button.

Rotate 2
1 Right-click Plane Geometry  and choose Transforms>Rotate .

2 Select the object copy2 only. 
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Note: If you cannot locate copy2 in the Graphics window, select View>Selection List and 
click to highlight copy2 in the list. Then right-click copy2 in the list to add it to the Input 

objects list.

3 Go to the Rotate settings window. Under Rotation Angle in the Rotation field, 
enter -120.

4 Click the Build Selected  button and then click the Zoom Extents  button on the 
Graphics toolbar.

The geometry should match this figure. 

Next, unite the three arms to one object.

Union 1
1 Under Work Plane 1 (wp1), right-click Plane Geometry  and choose Boolean 

Operations>Union .
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2 Select the objects r1, rot1, and rot2 only and add these to the Input objects list in the 
Union settings window.

3 Click the Build Selected  button. There is one object created called uni1.

Now, build the central connecting region and add the ferrite domain. During these 
stages, the geometric design parameters are used. Star t by creating a triangle 
connecting the arms and then by subtracting a copy of what has already been drawn 
from a circle of proper radius.

Circle 1
1 Under Work Plane 1 (wp1), right-click Plane Geometry  and choose Circle .

2 In the Circle settings window under Size and Shape, enter 0.2/(3*sqrt(3)) in the 
Radius field.

3 Click the Build Selected  button. 

Copy 3
1 Under Work Plane 1 (wp1), right-click Plane Geometry  and choose 

Transforms>Copy . A Copy 3 node is added to the sequence.

2 Select the object uni1 only.

Difference 1
1 Right-click Plane Geometry  and choose Boolean Operations>Difference .
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2 Select the object c1 only to add it to the 
Objects to add list in the Difference settings 
window.

3 Go to the Difference settings window. To the 
right of the Objects to subtract section, click 
the Activate Selection button . 

4 Select View>Selection List and click to 
highlight copy3 in the list. Then right-click 
copy3 in the list to add it to the Objects to 
subtract list.

5 Click the Build Selected  button.

The geometry should match this figure so far.
Tutorial Example: Impedance Matching of a Lossy Ferrite 3-port Circulator | 45



rf_introduction.book  Page 46  Monday, April 23, 2012  7:05 PM
Now, rotate the newly created triangle 180 degrees and use one scaled copy of it to 
create linear fillets for impedance matching. Use another scaled copy to define the 
ferrite.

Rotate 3
1 In the Model Builder under Work Plane 1 (wp1), right-click Plane Geometry  and choose 

Transforms>Rotate .

2 Select the object dif1 only.

3 Go to the Rotate settings window. Under Rotation Angle in the Rotation field, enter 180.

4 Click the Build Selected  button.

Copy 4
1 Right-click Plane Geometry  and choose Transforms>Copy .

2 Select the object rot3 only.

It is now time to apply the first scaling for the impedance matching.

Scale 1
1 Right-click Plane Geometry  and choose Transforms>Scale .

2 Go to the Scale settings window. Under Scale Factor in the Factor field, enter 
sc_chamfer (one of the parameters entered in the step “Global Definitions - 
Parameters and Variables” on page 19).

3 Select the object copy4 only.

4 Click the Build Selected  button.

Union 2
1 Right-click Plane Geometry  and choose Boolean Operations>Union .

2 Select the objects uni1 and sca1 only. Use the Selection List to select the objects if 
required.

3 Go to the Union settings window. Under Union click to clear the Keep interior boundaries 
check box.

4 Click the Build Selected  button.
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The geometry should match this figure.

Next, apply the scaling for the ferrite region.

Scale 2
1 In the Model Builder right-click Plane 

Geometry  and choose Transforms>Scale 
.

2 Select the object rot3 only.

3 Go to the Scale settings window. Under 
Scale Factor in the Factor field, enter 
sc_ferrite. 

4 Click the Build Selected  button. 

Extruding the 2D cross-section into a 3D 
solid geometry finalizes the geometry.

Extrude 1
1 Right-click Work Plane 1 (wp1)  and 

choose Extrude .

2 Go to the Extrude settings window. Under 
Distances from Plane in the associated table, enter 0.1/3 in the Distances (m) column.
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3 Click the Build Selected  button and then click the Zoom Extents  button on the 
Graphics toolbar.

Form Union
1 In the Model Builder, click Form Union (fin) .

2 In the Form Union settings window, click Build All .

The final sequence of Geometry nodes in the Model 

Builder should match the figure. 

The last step finalizes the geometry and turns it into 
a form suitable for the simulation by removing duplicate faces, for example. It is 
performed automatically when material is added or when physics are defined, but it 
is good practice to perform it manually as any error messages from this step may be 
confusing when appearing at a later stage. The geometry should match this figure.

Note: If you skipped to this section to learn how to create the geometry, you can now 
return to the next tutorial step: “Materials” on page 21.
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